Released January 29, 2014.

COMSOL programs are distributed in accordance with U.S. Export Administration regulations. They may be subject to U.S. Export Control laws or other (U.S. and non-U.S.) governmental export and import laws. It is the licensee¹s responsibility to comply with the latest U.S. or other governmental export or import regulations. Export or import in violation to applicable export control laws is prohibited. If you wish to submit materials to COMSOL in connection with any support request that must be restricted to U.S. persons under applicable export control laws, then you must submit such materials by email to: support@us.comsol.com.

This update corrects several bugs and stability issues in COMSOL 4.4. We recommend that you reapply the software update after installing new add-on products to an existing COMSOL 4.4 installation. Update Details.

Important
If you have a license for LiveLink™ for Inventor®, click here for further update instructions.

Installation

Check your version

Make sure that you run COMSOL version 4.4.0.150 or later. On the Help menu, click About COMSOL Multiphysics to check your version. If you have an earlier build number, contact your COMSOL sales representative to get the official release of COMSOL 4.4 before you proceed.

Download Update

Bullet Windows comsol_4.4.0.195_win.exe 57.8 MB
Bullet Linux comsol_4.4.0.195_linux.zip 85.5 MB
Bullet Mac OS X comsol_4.4.0.195_mac.dmg 57.9 MB

If you have a license for the MEMS Module, the Acoustics Module, or the Structural Mechanics Module, also download the additional update for these products

Bullet Windows comsol_4.4.0.195_piezo_win.exe 485 KB
Bullet Linux comsol_4.4.0.195_piezo_linux.zip 6 KB
Bullet Mac OS X comsol_4.4.0.195_piezo_mac.dmg 42 KB

If you have a license for LiveLink™ for Excel®, download also the additional update for this product

Bullet Windows comsol_4.4.0.195_llexcel_win.exe 1.2 MB

If you have a license for LiveLink™ for SolidWorks®, download also the additional update for this product

Bullet Windows comsol_4.4.0.195_llsw_win.exe 1.3 MB

If you have a license for LiveLink™ for Inventor®, download also the additional update for this product

Bullet Windows comsol_4.4.0.195_llinv_win.exe 994 KB

Finish the installation of the update, then to complete the installation of LiveLink™ for Inventor® follow these steps:

  1. Right-click the Inventor® icon and select Run as administrator.
  2. As the LiveLink™ add-in is loaded it completes the update, and in a few moments you should see the following message:

    The LiveLink for COMSOL (4.4) add-in has been updated. Please restart Inventor for the changes to take effect.

    This is normally sufficient and you can safely close Inventor®. If you however do not see this message complete these additional steps:

  3. Click the Add-Ins button on the Tools tab in Inventor® to open the Add-Ins Manager dialog box.
  4. Click LiveLink for COMSOL (4.4) in the list of add-ins.
  5. Select the Loaded/Unloaded check box if it is not already selected.
  6. The add-in is now loaded, and it completes the update. You should now see the above message.

If you do not see the above message, and the LiveLink for COMSOL (4.4) add-in is loaded, you can safely close Inventor® since this additional update step was not necessary.

Note that if you have several supported versions of Inventor® installed you only need to complete these steps with one supported version.


If you have a license for LiveLink™ for MATLAB®, also download the additional update for this product

Bullet Windows comsol_4.4.0.195_mli_win.exe 486 KB
Bullet Linux comsol_4.4.0.195_mli_linux.zip 6 KB
Bullet Mac OS X comsol_4.4.0.195_mli_mac.dmg 43 KB

Install

Before you proceed with the installation, make sure to exit any running COMSOL process.

Windows

Run the downloaded .exe-file to extract the update to the COMSOL 4.4 installation directory, for example C:\Program Files\COMSOL\COMSOL44.

Linux

Copy the downloaded .zip-file to the COMSOL 4.4 installation directory:

cp comsol_4.4.0.195_linux.zip [installdir]/comsol44

where [installdir] is the root of the installation, for example /usr/local. Unzip it by the commands:

cd [installdir]/comsol44
unzip -o comsol_4.4.0.195_linux.zip

Macintosh

Double-click the downloaded .dmg file to mount the disk image. In the Finder, open the mounted disk and double-click the COMSOL installer icon. Select your COMSOL installation folder, usually called COMSOL44.

Check your installation

  1. Start COMSOL Multiphysics.
  2. On the Help menu, click About COMSOL Multiphysics.
  3. Check that the version number is 4.4.0.195 (If not, the installation did not succeed).

Update Details

COMSOL Multiphysics

  • COMSOL now supports Simplified Chinese as one of the languages that you can choose to localize the COMSOL Desktop environment.
  • A Deselect Box button is now available to deselect (clear) all selections inside a rubberband box.
  • Improved stability and GUI performance.
  • Support for system fonts now works correctly.
  • Improved support for running COMSOL on computers with non-Latin usernames.
  • The convergence plot is now correct when using the double dogleg solver in a continuation sweep.
  • Plot while solving now updates only on the innermost study level.
  • The unit for Planck's constant (a predefined physical constant) now displays correctly.
  • New strings are available to distinguish "second" meanings in local languages: order (second is between first and third) versus time unit (a second is one 60th of a minute).
  • Corrected unit of measurement of inward flow condition in non-3D models using Transport of Diluted Species.
  • Keyboard accelerators now work correctly when running COMSOL on Ubuntu 12.04.
  • The eigenvalue solver now gives a warning if not all eigenvalues are found.
  • Reuse solution for previous step now works correctly for auxiliary sweeps of linear iterative solvers.
  • Disabled study steps are now shown with the correct indentation in the model tree.
  • The Time-explicit solver now correctly stores the solution at converged time steps if there is an error.
  • Plot while solving now works correctly when running from the API with a graphics server.
  • Settings window sections can now be expanded and collapsed using arrow keys in the Windows version of the COMSOL Desktop.
  • It is now possible to update model libraries also after choosing not to install models during the initial software installation.
  • Changing the order of table entries now works correctly when defining polygons using tables.

AC/DC Module

  • External Current Density will no longer be applicable together with E-J characteristic.
  • Several GUI stability improvements.
  • The Thin low permittivity gap condition now works together with a moving mesh.

Acoustics Module

  • Several GUI stability improvements.
  • Modified the material properties of Quartz to include both right- and left-handed properties defined according to the two commonly used standards.

CFD Module

  • The unit of the drag coefficient in the Euler-Euler Model interface is now correct.
  • Performance improvements for Reacting Flow, low-Re k-epsilon.
  • Stability improvements for some analyses in Spallart-Allmaras turbulence model.
  • Stability improvements for Wire gauze.
  • Stability impovement for Laminar outflow conditions for some solver selections.

Chemical Reaction Engineering Module

  • Corrected unit of measurement of the Equilibrium Constant in the Reaction Engineering interface.
  • CHEMKIN kinetic data import corrected for third-body reactions.
  • Several GUI stability improvements.

Electrochemistry Module

  • Stability improvements to moving boundary problems in 2D axisymmetric models.

Fatigue Module

  • The elastic solution with notch assumption in the strain-based fatigue has been corrected. A distinction between tensile and compressive stresses is now made.

Heat Transfer Module

  • Discontinuous (default) and continuous Lagrange elements are now available for damage integral dependent variables discretization.
  • Variable definition for boundary heat source variable is now synchronized with the user input.
  • Use of prefix in variables names now prevents duplicate variable names when multiple pair temperature continuity conditions are active on the same boundary.
  • Duplicate plot groups in postprocessing menus have been removed.
  • Saturation pressure computation is more accurate, especially for temperatures far from 100 °C.
  • Corrected revolution angles in the default plot of the 2D axisymmetric version of Heat Transfer in Thin Shells.

MEMS Module

  • Modified the material properties of Quartz to include both right- and left-handed properties defined according to the two commonly used standards.
  • Corrected a problem which caused pressure follower loads to be applied in the wrong direction in some circumstances within the Electromechanics interface.
  • Fixed an issue with the expression for the time averaged heat source variable created by the Thermoelasticity interface.

Molecular Flow Module

  • It is now possible to apply the Number Density Reconstruction feature to Axial Symmetry boundaries.

Optimization Module

  • The BOBYQA optimization solver now correctly disregards unsupported constraints.
  • The BOBYQA optimization solver now respects the setting for maximum number of simultaneous function evaluations also for the initial evaluation.
  • The handling of axisymmetric or renamed coordinates with the Least-squares optimization objective has been corrected.

Particle Tracing Module

  • The Coulomb and Lennard-Jones Particle-particle interaction forces now take into account the out-of-plane position when the Include out-of-plane degrees of freedom property is active.
  • The equation display for the Monte Carlo collision model option in the Elastic Collision Force has been corrected.
  • The out-of-plane velocity now correctly takes into account changes in the particle mass when the Include out-of-plane degrees of freedom property is active.
  • The out-of-plane particle velocity is now updated correctly when the Include out-of-plane degrees of freedom property is active and the Bounce option is used in the Wall boundary condition.
  • Field-dependent forces can now be assigned to a subset of domains.
  • Equation display for normal Inlet velocity is now correct.

Pipe Flow Module

  • Pumps, bends, and valves in the Pipe Flow Module now work with moving meshes.
  • Corrected problem with when adding wall layers to rectangular pipe shapes.

Plasma Module

  • Importing a Chemkin thermo or transport file now works correctly in the Plasma Module physics interfaces.
  • Units for the forward rate constant in the Electron impact reaction and Reaction features are now correct.

RF Module

  • Second-order scattering boundary condition can now be used in 2D axisymmetry.
  • Stability and accuracy improvements.

Semiconductor Module

  • Fixed an issue with certain options for the initial conditions when the Semiconductor interface is coupled to the Heat Transfer in Solids interface.
  • Corrected the variable displayed next to the user input for the Relative Acceptor Energy for the Incomplete Ionization settings in the Semiconductor Material Model node.
  • Improved the smoothing settings for 1D default plots.
  • Nonfunctional user inputs in the User Defined Recombination feature no longer appear in the user interface.

Structural Mechanics Module

  • It is now possible to model friction together with rigid domains.
  • Using rigid connectors in a Shell interface now works as expected also if the model contains a Solid Mechanics interface.
  • When using a Rigid Connector with a Mass and Moment of Inertia subnode in the Shell interface, generation of the solver sequence could fail for a Transient solver.
  • Coriolis forces in frequency domain analysis have been corrected.
  • Modified the material properties of Quartz to include both right- and left-handed properties defined according to the two commonly used standards.

ECAD Import Module

  • Fixes issue with parsing of certain ODB++ archives.
  • Fixes issue with decompression of certain ODB++ archives.

LiveLink™ for Excel®

  • The LiveLink add-in is now correctly installed for 64-bit version of Excel.
  • The LiveLink add-in can now be loaded by 64-bit Click-to-Run version of Excel 2013.
  • Materials with uppercase letters now appear correctly in the Material Browser after export from an Excel spreadsheet.
  • The correct unit is now displayed for stress tensor in the settings for material export.
  • Material property names are now used to generate the function names for field-dependent material properties.
  • Several stability improvements.

LiveLink™ for SolidWorks®

  • Fixes problem with disappearing COMSOL Multiphysics tab in SolidWorks after de-activating and re-activating the LiveLink add-in.
  • Several stability improvements and corrections for the bidirectional and the One Window interfaces.

LiveLink™ for Inventor®

  • Selections for materials are now synchronized for surface bodies in assembly components.
  • Assemblies with surface bodies in components are now synchronized.
  • Selections for materials are now synchronized for surface bodies in part files.
  • Fixes problem with unloading of certain add-ins when loaded in Inventor at the same time as the LiveLink add-in.
  • Several stability improvements and corrections for the bidirectional and the One Window interfaces.