System Requirements - 4.4 General

These requirements are common to all platforms:

  • A working network card and internet connection is recommended during installation.
  • At least 1 GB memory, but 4 GB per processor core or more is recommended.
  • 1-5 GB of disk space, depending on your licensed products and installation options.
  • Adobe Acrobat® Reader 9.0 or later to view and print the COMSOL® documentation in PDF format.

Floating Network Licenses

The floating network license type is supported on heterogeneous networks of Windows®, Linux®, and OS X computers. Both the license manager and the COMSOL® software can run on either Windows®, Linux®, or OS X, and a single computer can run both of them. This license type is recommended for best high-performance computing (HPC) performance and is required for distributed-memory parallelism including hybrid modeling.

Operating System Requirements

Windows® Mac OS X Linux®
32-bit Operating Systems Windows® 8.1
Windows® 8
Windows® 7
Windows Server® 2008
Windows Vista®
Windows Server® 2003 with Service Pack 2 or later
Windows® XP with Service Pack 3 or later
- Debian® 5.0, 6.0 and 7.0
OpenSUSE® 11.3
RedHat® Enterprise Linux® 5* and 6.0-6.5
Ubuntu® 10.04 and 12.04 LTS
64-bit Operating Systems Windows® 8.1
Windows® 8
Windows® 7
Windows Server® 2012
Windows Server® 2008 R2
Windows Server® 2008
Windows HPC Server® 2008 R2
Windows HPC Server® 2008
Windows Vista®
Windows Server® 2003 x64 Edition with Service Pack 2 or later
Windows® Compute Cluster Server 2003 with Service Pack 1 or later
Windows® XP Professional x64 Edition with Service Pack 2 or later
Mac OS X® 10.6, 10.7, 10.8, and 10.9 Debian® 5.0, 6.0 and 7.0
OpenSUSE® 11.3
RedHat® Enterprise Linux® 5* and 6.0-6.5
Ubuntu® 10.04 and 12.04 LTS

* RedHat® Enterprise Linux® 5 is only supported for server, batch, and cluster operation.

OS Specific System Requirements

64-bit Mac OS X® Java® 1.6
In Mac OS X® 10.6 Java® is included by default.
In Mac OS X® 10.7, 10.8, and 10.9 you need to download and install Java®.


CAD Import Module requires 64-bit Mac OS X® 10.7 or later.
32-bit Linux® GNU C Library version 2.3.4 or later1
Linux® kernel 2.6.18 or later
Intel® Pentium® IV or AMD Athlon® XP processor or later
64-bit Linux® GNU C Library version 2.3.4 or later1
Linux® kernel 2.6.18 or later
Intel® Pentium® IV or AMD Athlon® XP processor or later.

1 If you have an older version of libstdc++ than 6.0.9 you may need to start comsol with the option -forcegcc

Graphics System Requirements

COMSOL® recommends hardware rendering for performance reasons. Hardware rendering requires drivers that support OpenGL® version 1.4. Windows® users may also use DirectX® version 9 on the local console. Hardware rendering requires at least 24-bit color graphics.

Alternatively, software rendering can be used. The Optimize for Quality setting in graphics preferences requires OpenGL® 2.0. Software rendering also supports 16 bit color graphics. For performance reasons, we recommend that the graphics card has at least 512MB memory.

  Card Model Operating System Driver Version
Windows® FirePro™ V3900 Windows® 7 8.911.3.1-120116a-132089E
FirePro™ V4900 Windows® 7 8.85.7.1-110717a-124599C
FirePro™ V5900 Windows® 7 8.85.7.2-110901a1-125182C
FirePro™ V7750 Windows Server® 2008 R2 HPC 8.540.0.0
FirePro™ V7800 Windows® 7 8.85.7.1-110717a-122786C
FirePro™ V7900 Windows® 7 8.83.5.4-110520a-119550C
FirePro™ W5000 Windows® 7 8.982.2
FirePro™ W7000 Windows® 7 8.982.2
Quadro™ K5000 Windows® 8 9.18.13.3187
Quadro™ K2000 Windows® Vista 9.18.13.3182
Quadro™ K600 Windows® 8.1 9.18.13.3182
Quadro™ 600 Windows® Vista 32-bit 9.18.13.3182
Quadro™ 410 Windows® 7 9.18.13.3182
Quadro™ FX 3800 Windows® Server 2008 R2 8.17.12.7614
Quadro™ FX 540 Windows® XP 32-Bit 6.14.12.7614
Quadro™ FX 540 Windows® XP 64-Bit 6.14.12.7565
Quadro™ FX 550 Windows® Vista Pro 64 Bit 7.15.10.9746
Quadro™ FX 580 Windows® 7 8.16.11.9175
Mac OS X GeForce™ GT 120 Mac OS X® 10.6 -
Linux® * FirePro™ V4800 Ubuntu® 10.04 LTS 8.723.1-10048a-09850C-ATI
Quadro™ FX 1800 Debian® 6.0 195.36.31

The graphics cards listed above have been rigorously tested for compatibility with COMSOL Multiphysics. Please note, however, that other AMD or NVIDIA graphics cards may also be compatible with COMSOL Multiphysics. Graphics cards that belong to the same model series as one of the cards listed above are more likely to be compatible with COMSOL Multiphysics.

* For hardware acceleration on Linux, use proprietary drivers from you graphics card vendor, such as NVIDIA or AMD, otherwise use COMSOL software rendering. The Nouveau video driver is only supported for software rendering.

Officially Supported Compilers

Windows® Mac OS X Linux®
External Function C Visual Studio® 2010 Intel® Composer XE 2013.3 (also known as Intel® Compiler version 13.0.2) with GCC 4.2.1 is officially supported Intel® Composer XE 2013.4 (also known as Intel® Compiler version 13.1.2) with GCC 4.2.1 is officially supported
Java® API JDK 1.6 or lower JDK 1.6 or lower JDK 1.6 or lower

Parallel System Requirements *

Windows® Mac OS X Linux®
Shared-memory Parallelism 32-bit and 64-bit Supported Versions of Windows® 32-bit and 64-bit Mac OS X® 32-bit and 64-bit Linux® Distributions
Distributed-memory Parallelism Windows® Compute Cluster Server 2003 with Service Pack 1
Windows HPC Server® 2008
Windows HPC Server® 2008 R2
Not Supported RedHat® Enterprise Linux® 5 and 6.0-6.5, Debian® 6, and Ubuntu® 12.04.

All computers in the cluster must use the same Linux® version and should have similar hardware. It is recommended that OpenFabrics Enterprise Distribution (OFED) 1.4 or higher is installed. If you are using an RDMA-capable network fabrics a DAPL 1.2 or later version compliant driver or library is required. The software is usually provided with your hardware

* COMSOL is a proud member of the Intel® Cluster Ready program and certifies COMSOL Multiphysics with every new version. View Certificate. The certification process ensures that COMSOL Multiphysics will seamlessly work for parallel processing and cluster modeling on any hardware that has also been certified as being Intel Cluster Ready.

Intel Cluster Ready
Intel, Intel Cluster Ready and the Intel Cluster Ready text treatment are trademarks of Intel Corporation in the U.S. and other countries.

FLEXnet License Manager

FLEXnet version 11.5 is used on Windows and Linux. FLEXnet version 11.6 is used on Mac. The version of lmgrd must be the same or higher than the FLEXnet version used by COMSOL.

Internet Protocol Support

Windows® Mac OS X Linux®
IPv4 Yes Yes Yes
IPv6 Yes No Yes

NOTE:This information is provided for your benefit but should not be used as a substitute for your own investigation of the system requirements that may be appropriate for your use of COMSOL® software or other software, given your particular circumstances. Systems and hardware change regularly, which may impact any determination of what system requirements are appropriate you.

Version 4.4
Version 4.3b